Systemvoraussetzungen für die XoniC Shopsoftware

Sollten Sie die XoniC Shopsoftware auf einem eigenem Server/Hosting installieren wollen, so beachten Sie bitte die folgenden Serveranforderungen.

 

Optional bieten wir unseren Kunden auch Hosting auf speziell für unsere Shopsoftware konzipierten Servern an.

Systemvoraussetzungen

Serveranforderungen:

Die XoniC-Shopsoftware läuft ohne Einschränkungen bei fast allen Providern.

Folgende Voraussetzungen sollten erfüllt sein:

  • Linux basierter Web-Server**
  • PHP-Version ab 5.6 (empfohlen ab 7.0)
  • MySQL-Version ab 5.0 (empfohlen ab 5.5)
  • GD Support ab Version 2
  • memory_limit (mindestens 64MB, empfohlen 128MB oder mehr)
  • ionCube Loader
  • mod_rewrite*
  • cURL*
  • dom*
  • zip*
  • ZLib*
  • allow_url_fopen*
  • register_globals aus*
  • file_uploads an*

* Empfohlen, jedoch nicht zwingend zum Shopbetrieb notwendig!
** Betrieb auf Windows Servern ab PHP 5.6 möglich, jedoch bieten wir für die Installation auf Windows-Servern keinen Support an


Das Grundsystem erfordert ca. 50 MB freien Speicherplatz zzgl. Ihrer Produktbilder sowie Datenbanksicherungen

Sollten Sie sich nicht sicher sein, ob Ihr Webhosting die oben genannten Serveranforderungen erfüllt, nutzen Sie unseren "Installations-Check".
Installations-Check herunterladen


Sie müssen diese Datei nur herunterladen, entpacken, sowie den Inhalt (xoTester.php) auf Ihren Webserver übertragen (zum Beispiel per FTP) und über Ihren Browser (http://www.ihre-domain.de/xoTester.php) aufrufen. Gern können wir auch vorab testen, ob der XoniC-Webshop auf Ihrem Webhosting läuft. Nehmen Sie dazu Kontakt mit uns auf.

Sollten Sie kein Hosting besitzen oder den Hoster wechseln wollen, so beachten Sie auch unsere speziell für Webshops optimierten Hostinglösungen. Schauen Sie dazu Links unter dem Punkt "Webshop Hosting".